// This is the script to give summary on the main page.
Think IPM

Tuesday, June 17, 2008

Cookie Required error when running Citrix AGEE with XDS

Another Great Tip from David Paoleschi.

If you get the “Cookie Required” error when you running AGEE with XDS (that WI 5.0). This is because the change of cookies.js (Inetpub\wwwroot\Citrix\XenApp\app_data\clientscripts) in WI 5.0.

To get around this issue, open the cookies.js, you can find the line:

document.cookie = name + "=" + value + "; path=<%=wiContext.getWebAbstraction().getAbsoluteRequestDirectory()%>";

change it to the following and save the file:

document.cookie = name + "=" + value + ";

The problem will disappear. However, I am not sure if there is any adverse effect by doing this, so use this with care.

blog comments powered by Disqus Blog Widget by LinkWithin